Jump to content
Moses Ludel

In addition to the topic discussion below, there are lengthy and useful discussions on Jeep 4.0L cylinder misfire codes and possible remedies at these two additional topic links:

 

Message added by Moses Ludel

Recommended Posts

random, intermittent #1 cylinder misfire. I have replaced the coil-pac, #1 injector, spark plugs, and both upstream O2 sensors. engine leakdown and compression normal though #1 slightly lower in compression. emissions always meet I/M standards (no certificate of waiver needed). have all heat shields including #3 injector so vapor lock not issue.  engine runs good when not misfiring though does have a slight roughness noticeable when at idle. Is there any way to check the current of an injector wire or plug while engine is running and showing symptoms to see if all is well in the wiring harness?  engine bay is quite clean for 235k mi. and no noticeable damage to wiring harness, but there could be a partial open in a circuit I suppose. Any ideas? don't know where to go from here with repairs/diagnosis etc. Oh, misfire occurs mostly after engine has been under normal-use-load for a couple hours or so, but not always. sometimes it is misfiring at cold-start.

Share this post


Link to post
Share on other sites

love/hate4.0L...This is often an erroneous code throw.  Is the engine actually misfiring?  Years ago, an oscilloscope engine analyzer would clear this up, showing both ignition misfire or a lean burn/poor fuel combustion, but today, we rely on PCM thrown "reliable" trouble codes.  This one is often misdiagnosed at the expense of unnecessary parts change-outs.

There are simple testers for coil pac firing (surface induction test) and injector current pulsing.  If you have access to these tools, you can see whether there is a true "misfire" (ignition or fuel injector) at #1 cylinder or any other.  Try to see whether there is real cause for mechanical work or not.  Here are two useful and quick probe testers:

https://www.amazon.com/Waekon-76562-Quick-Variable-Sensitivity/dp/B0021UPE58/ref=pd_sbs_263_1?ie=UTF8&pd_rd_i=B0021UPE58&pd_rd_r=D27F1SN4HNCYE02FKCQK&pd_rd_w=9zhVU&pd_rd_wg=ftUpB&psc=1&refRID=D27F1SN4HNCYE02FKCQK

https://www.amazon.com/Waekon-76462-Universal-Electronic-Injector/dp/B0021V0FRE/ref=sr_1_1?s=automotive&ie=UTF8&qid=1474650045&sr=1-1&keywords=waekon+injector+tester

Here are two threads/topics where we have covered on this issue:

 

 

Read through these topics.  If you're still not getting the results you want, let us know...I'll gladly continue the discussion.

Moses

Share this post


Link to post
Share on other sites

×
×
  • Create New...