Jump to content
David Johnson

1988 YJ 2.5 erratic fuel pressure

Recommended Posts

New to the group, but have already found it the be very helpful.  So here's my issue.  

 

I have an 88 YJ with a TBI 2.5 that is giving me a headache!!  It starts, runs and revs just fine. Warm or cold.  But under a load (upon initial take off) it stubbles and will eventually die. Then it's a hard start.   I removed the fuel filter and replaced with a fuel pressure guage.  After it's been acting up, it doesn't idle well either.  When it stumbles on idle, the pressure is dropping from 17lbs to 10 or even below at times.  I've rebuilt the throttle body and replaced the regulator at the time.  Should I assume a bad fuel pump or something else?

Share this post


Link to post
Share on other sites

Sensible approach, David...10 PSI or below is very low and unacceptable pressure.  Pressure should not fluctuate from 17 PSI down to 10 PSI when measured at the regulator/TBI unit.  If the regulator is holding properly, this is either a fuel pressure or fuel volume problem.

Pressure and volume are related.  If either is off, the fuel pressure at the TB unit will be too low.

You hooked up the pressure gauge at the fuel filter location on the frame rail.*  You want to first confirm that the pressure regulator is not defective, that it is holding normal pressure.  If the regulator is functioning correctly, you have a pump issue if the pressure at your gauge is very low.

*You need to restore the filter ASAP, or debris will reach the regulator and fuel injector!

A quick check for pump output pressure is to pinch the fuel hose on the engine side of the gauge while the pump is operating.  Pinch for just long enough for the highest pressure to register on the gauge, then immediately release the stoppage.  In this case, you're reading just the pressure from the pump to the gauge, without the regulator bleeding off pressure.

If the pressure is normal from the pump to the gauge and the pinched off hose, confirm the fuel flow volume.  Disconnect the hose at the engine side of the gauge and very carefully feed a piece of hose into a metal can.  (No fires, sparks or gasoline in your eyes!  Protect yourself with goggles and gloves.)  Activate the fuel pump and make sure the fuel flow into the metal can looks normal and unrestricted.  If flow is not normal, the pump could be defective, or the pump filter (tank floor sock) could have a restriction.

Note:  If the engine runs well at higher engine speeds under load, the pump is not a likely source of trouble.  

We have covered your 2.5L TBI engine's symptoms from every angle in our forum discussions.  Use the search box and enter:  "2.5L TBI Troubleshooting".  This particular topic and thread will be helpful: 

We'll go from there...

Moses

Share this post


Link to post
Share on other sites

You were very thorough in your approach, David, glad the source has been discovered.  A loose ground wire on the pump will do it!

Reinstall the OEM fuel filter to protect the TBI system.  The fuel pressure gauge is a good idea, maybe you can relocate it with a "T" at the TB unit and use steel fuel tubing or high pressure EFI hose and EFI clamps for a safe installation.  You could quickly troubleshooting EFI pressure or fuel regulator issues.

Good job!  Not that easy to remove the fuel tank, but you solved the problem.

Moses

Share this post


Link to post
Share on other sites

×
×
  • Create New...