Jump to content
Free Membership Now Includes Posting and Reply Privileges to Help Meet Your Transportation Needs During the COVID-19 Health Crisis! ×

Recommended Posts

My son has a 1994 Cherokee Country, 4.0 that starts fine and runs fine, but when you shut it off, it will not restart until it has cooled off. I replaced the ignition coil but the problem did not change. My son has purchased a crankshaft position sensor, but before we install it, I wanted some opinions from other XJ owners who may have experienced the same problem. Once we have installed the crankshaft position sensor, it cannot be returned if it doesn't fix the problem. I am not even sure that not starting when hot is a symptom of a bad crankshaft position sensor. Someone that my son knows suggested it. Any help or opinions would be greatly appreciated since we cannot really afford to just randomly replace parts in search of a fix. I have owned many Jeep Wranglers over the years, but never had a problem like this. Thanks. 

Share this post


Link to post
Share on other sites

Have you verified that you have no spark during the no-start?  If so, I think the CPS is a good possibility.  Just be sure to install a quality one (Mopar or Echlin).  The cheap aftermarket replacements are notoriously unreliable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...