Jump to content

Search the Community

Showing results for tags 'ecu board diagnosis repair'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Jeep® 4WD Owners Group
    • Vintage Jeep® Vehicles 1941-71
    • 1972-86 AMC/Jeep® CJ and Jeepster Models
    • Jeep® YJ Wrangler, TJ Wrangler and LJ Wrangler
    • 2007-Up Jeep® JK Wrangler 4x4
    • Jeep® XJ Cherokee, MJ Comanche Pickup and Grand Cherokee
    • FSJ Models: Full-Size Jeep® Gladiator and J-Truck, Cherokee, Wagoneer and Grand Wagoneer
    • Jeep® Liberty, Commander and Patriot
  • Dodge Power Wagon, Dodge and Ram 4WD Trucks
    • Dodge 4x4 and Ram 4WD Trucks
    • Dodge-Ram Cummins Power
    • 1941-1980: Dodge Military Trucks and Civilian W-Series Power Wagon
  • Chevrolet & GMC 4x4 Trucks and SUVs
    • Vintage to 1991: Chevrolet & GMC NAPCO and K-Model 4x4 Trucks
    • 1987-Present: Chevrolet & GMC Silverado, S-Trucks and 4x4 Suburban, Yukon and Blazer
    • Humvee and Hummer H1, H2 and H3 Forum
  • Ford 4x4 F-Series, Full-Size SUV and Ranger Trucks, Bronco II and Explorer
    • 1948-Present: Ford F-Series Trucks
    • Full-Size Ford SUV, Bronco 4x4, Excursion and Expedition
    • Ford Power Stroke Diesels
    • Ford Ranger, Bronco II, Explorer and Mercury Mountaineer
  • International-Harvester 4x4 Light Trucks, Scout and Scout II
    • International-Harvester 4x4 Light Trucks, Scout and Scout II Forum
  • Toyota Truck, Land Cruiser, FJ Cruiser, Toyota SUV and Lexus 4WD
    • Land Cruiser 4WD FJ, DJ and FJ Cruiser
    • Toyota Sequoia, Lexus, Highlander and Rav4
    • Toyota 4WD Pickup, Hi-Lux, Tacoma, Tundra and 4Runner
  • Datsun and Nissan 4x4 Trucks, Pathfinder and Xterra
    • Nissan Patrol, Pathfinder, Xterra and SUV 4x4s
    • Nissan 4WD Pickups: Datsun, Nissan, Frontier and Titan
  • 4WD Land Rover Community
    • Land Rover, Discovery & Defender 4x4s
  • 4x4 Suzuki Samurai and Sidekick/Geo Tracker
    • Suzuki 4x4 Samurai
    • Suzuki Sidekick and Geo Tracker
  • Isuzu 4x4 Pickups and SUVs
    • Isuzu 4x4 Pickups and SUVs
  • Travel Trailers, Toy Haulers, Tent Trailers and Military Surplus Trailers
    • Travel Trailer and Toy Hauler Forum
    • Military Surplus M415, M416 and Other Off-Road Trailers
    • Tent Trailers and Trailering
  • 4x4 and Single-Track Travel & Adventure Destinations!
    • Places You Have Been...
    • Places You Would Like to Travel!
    • Off-Pavement Travel Gear
    • Equipping Your 4x4 for Overland Travel
    • Health and Fitness for Four-Wheelers and Powersports Enthusiasts
  • Dirt & Dual-Sport Motorcycles
    • Dirt & Dual-Sport Motorcycles
    • Dual-Sport and Dirt Motorcycle Equipment for Overlanding
  • Quad ATV, UTV and Side-by-Side 4x4s
    • 'Quad' ATV, UTV and Side-by-Side 4x4s!
  • Welding, Metal Fabrication and Metallurgy Discussion
    • Welding and Metal Fabrication Forum
    • Metallurgy and Heat Treating Forum
  • The Right Tools and Equipment
    • Garage Tools and Equipment
    • Diagnostic and Specialty Tools & Equipment
    • Tool and Equipment Sources
  • Let's Talk and Share!
    • General Repairs and Tips (See Other Forums for Specific Vehicle Topics)
    • Off-Topic and General Discussion
    • Sharing New Products
    • Calendar Events and Outdoor Activities
  • Parts for Sale, Swap or Wanted
    • Parts for Vintage (1941-71) Jeep Vehicles
    • Parts for AMC/Jeep CJ, FSJ Cherokee, Grand Wagoneer and XJ Cherokee/Comanche
    • Parts for 1987-up Wrangler Models, Grand Cherokee and Liberty
    • Parts for 4x4 Dodge and Ram Trucks
    • Chevrolet & GMC Truck Parts
    • Parts for I-H Trucks and Scout/Scout II
    • Parts for Toyota, Nissan and Other Import 4x4 Trucks and SUV Models
    • Parts for Motorcycles, ATVs, UTVs and Snowmobiles
  • Equipment and Tools Classified Ads
    • Hand and Power Tools for Sale
    • Garage and DIY Equipment for Sale
    • Tools and Equipment Wanted

Blogs

  • 2018: "Year of Speaking Out!"

Product Groups

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi Guys! I've scoured these pages the last couple days, but can't find anything that matches my specific dilemma. I have a 1990 Wrangler w/ 150k miles on it, recent acquisition by my future son-in-law. It was running relatively fine, but it quit suddenly on a recent trip. It started cutting out when hitting bumps, then finally quit altogether. After dragging it home, hitting the forums, swapping a few parts, following all the sensor tests and wrapping my head around this TBI setup, I am afraid I have a partially dead ECU. -All ignition parts replaced- Ignition Module, Coil, Wires, Cap and Rotor, Plugs. -The truck will crank the engine just fine, but has NO spark at coil or plugs, and NO gas at the injector. The fuel pump comes on with ignition switch for 1-2 sec, there is fuel in the line at the throttle body, I have not checked fuel pressure yet. -A new CPS was installed, I checked the CPS, 217 Ohms (slightly low), 0.54 VAC while cranking the engine. - All other sensors checked out nominal. There is 5 VDC to the TPS and MAP sensors, so the ECU is not entirely fried. -While tracing the sensor wiring, I found a wire broken internally between the CPS sensor and the ECU (red-white wire tied to pin 28), I'm guessing that was the root cause of the failure. I'm afraid the ECU board may have been damaged in the process of the wire failing while driving. -I am looking for information about what I should be seeing for the output signals for the Ignition Module and Fuel Injector from the ECU. I expect they will be low voltage AC pulses, grounding the DC power supplied to the Ignition Module and the Injector. I have not found any specifications for the AC voltage or pulse duration for either the Ignition at pin 27 or Injector at pin 21 of the ECU. I measured both of these signals while cranking the engine, I got ~0.1 VAC at the injector, and basically zero (0.004 VAC) at the ignition module output. These numbers lead me to believe that the output drivers for these functions are damaged or dead, although I can see no signs of physical damage, no burnt smell, melted traces, cracks, or corrosion anywhere in the ecu components. Is there any function programmed in the ECU which would completely shut down the spark- and injector-outputs based on some combination of other inputs for some safety reason ? Any info on the specific layout of components relating to the Ignition and Injector Drivers in the 1987-1990 ECU would be greatly appreciated! And Thank You to all who have gone before me here, the info trail has been invaluable!!
×
×
  • Create New...